华为路由器6to4隧道原理及配置

6to4,华为路由器6to4隧道原理及配置                                                                                     

华为路由器6to4隧道原理及配置

6to4,华为路由器6to4隧道原理及配置

                                                                                      6to4                                                                                                           

先来进行原理的简单讲解:

华为路由器6to4隧道原理及配置

  •  FP:可聚合全球单播地址的格式前缀(Format Prefix),其值为001
  • TLA:顶级聚合标识符(Top Level Aggregator),其值0x0002
  • SLA:站点级聚合标识符(Site Level Aggregator)

6to4地址可以表示为2002::/16,而一个6to4网络可以表示2002:IPv4地址::/48,6to4地址的网络前缀长度为64bit,其中前48个bit(2002:a.b.c.d)被分配给路由器上的IPv4地址决定了,用户不能改变,而后16位(SLA是)由用户自己定义的 :

华为路由器6to4隧道原理及配置

一个IPv4地址只能用于一个IPv6隧道的源地址,如果一个便捷设备连接了多个6to4网络使用了同样的IPv4地址作为隧道源地址,则可以使用6to4中的SLA ID来区分,但他们共用一个隧道:

华为路由器6to4隧道原理及配置

                                                                                                                                                                      以上来自华为技术手册

------------------------------------------------------------------------------------------------------------------------------------------

以下是2002:IPv4-Addr1::/64如何得出的算法,例如你的接口G0/0/1的接口IPv4地址为192.168.10.1,算法如下:

首先将192.168.10.1写作二进制数,也就是1100 0000.1010 1000.0000 1010.0000 0001,那么在将这些数字4位4位的转成16进制数,也就是1100=C,0000=0,1010=A,1000=8,0000=0,1010=A,0000=0,0001=1,再将这几个他们结合起来也就是,C0A80A01,然后在他的中间插入一个冒号,也就是C0A8:0A01,然后再加入2002:IPv4-Addr1::/64,也就是2002:C0A8:0A01::/64,所以与12.1.1.1对应的隧道源地址就是2002:C0A8:0A01::/64中的一个地址,可以是2002:C0A8:0A01::1,在之后示例中会看到,以下为示例拓扑:

华为路由器6to4隧道原理及配置

 ##你要确定R2,R3是双栈路由器,也就是同时支持IPv4/6的转发,否则无法完成实验

以下是基础环境配置(全局使能IPv6,配置IPv6地址):

[R2]ipv6 

[R2-GigabitEthernet0/0/1]interface g0/0/2

[R2-GigabitEthernet0/0/2]ip address 12.1.1.2 255.255.255.0

[R2]interface g0/0/1

[R2-GigabitEthernet0/0/1]ipv6 enable

[R2-GigabitEthernet0/0/1]ipv6 address 2010::2/64

[R3]ipv6 

[R3]interface g0/0/1

[R3-GigabitEthernet0/0/1]ipv6 enable

[R3-GigabitEthernet0/0/1]ipv6 address 2020::3/64

[R3-GigabitEthernet0/0/1]interface g0/0/2

[R3-GigabitEthernet0/0/2]ip address 12.1.1.3 255.255.255.0

隧道配置如下: 

[R2]interface tunnel0/0/2    

[R2-Tunnel0/0/2]tunnel-protocol ipv6-ipv4 6to4

[R2-Tunnel0/0/2]source 12.1.1.2

[R2-Tunnel0/0/2]ipv6 enable

[R2-Tunnel0/0/2]ipv6 address 2002:0C01:0102::1/64

##这里的算法就是将12转成16进制数,然后一位一位的算出来,只要掌握进制转换这个并不难

[R3]interface Tunnel0/0/2

[R3-Tunnel0/0/2]tunnel-protocol ipv6-ipv4 6to4

[R3-Tunnel0/0/2]source 12.1.1.3

[R3-Tunnel0/0/2]ipv6 enable

[R3-Tunnel0/0/2]ipv6 address 2002:0C01:0103::1/64

路由配置:

[R2]ipv6 route-static 2002:C01:103:: 64 Tunnel0/0/2

[R3]ipv6 route-static 2002:C01:102:: 64 Tunnel0/0/2

##配置通往对方隧道接口IPv6地址的路由

[R2]ipv6 route-static 2020:: 64 2002:C01:103::1

[R3]ipv6 route-static 2010:: 64 2002:C01:102::1

##配置通往对方IPv6网络的静态路由

在R2去Ping向R3的隧道接口,测试联通性:

华为路由器6to4隧道原理及配置

 先要通过R2到R3的Ping测试,随后再使用PC1PingPC2:

华为路由器6to4隧道原理及配置

 ##如果你发现R2PingR3不通,则有可能是隧道的IPv6地址算错了,或者静态路由打错了,这些小错误挺容易犯的

 

博主现为上海思邱实业公司总经理,诚意招商

营业范围:联想戴尔等主流厂商服务器,办公电脑,显示器

华为华三思科等主流厂商数通产品,路由器,交换机,防火墙,无线等等

提供企业网络应急维修,网络周期性维护,服务器应急维修,服务器周期性维护,云计算部署,云存储部署等等各种各样的服务

只要你有IT行业相关的需求,那就可以联系我们

联系方式:17621969147 李先生

 

华为路由器6to4隧道原理及配置的相关内容如下:

标题:华为路由器6to4隧道原理及配置|http://www.wc10086.cn/413523.html

本文来自网络,不代表本站立场,转载请注明出处!